Исчисленный налог

Общепринятый порядок

Исчисление удержания, а также перечисления налога имеет следующий порядок:

  1. Произведение исчисления налога по всем доходам (в конце месяца).
  2. Удержание исчисленного налога во время выплаты дохода по факту.
  3. Произведение перечисления налогов обоих типов во время получения средств в банке, чтобы выплатить работникам доход.

Согласно данному порядку, получается, что удерживать работодатель может только исчисленный налог, а перечислять можно исключительно удержанный НДФЛ. Соответственно, невозможно как перечисление неудержанного налога, так и удержание неисчисленного.

Рассмотрим порядок более подробно. Первый этап – исчисление налога. Производится оно по итогам отчетного периода, обычно в конце каждого месяца, а также на основании всех доходов, которые получает сотрудник в течение отчетного периода. Соответственно, чтобы исчислить налог, необходимо понимать, какие именно доходы были получены работником за месяц. Дата исчисления налога обычно совпадает с последним днем в месяце.

Затем исчисленный налог необходимо удерживать. Делается это во время первой выплаты дохода. В момент получения в банке средств на выплату зарплат рабочим, работодатель в это же время выплачивает налог, который уходит в государственный бюджет.

Получается, что с доходов в текущем месяце не может быть налоговых перечислений в течение этого же месяца. Для данного типа выплат налог перечисляется не позже наступления последнего дня в месяце.

Чем характерен налог исчисленный и удержанный в НДФЛ

Итак, исчисленный налог можно узнать посредством умножения суммы НДФЛ, которая была исчислена ранее, на ставку налогообложения. Во время проведения расчетов стоит обращать внимание на то, что полученная прибыль может быть меньшей на сумму вычтенных налогов. Прописывается исчисленный НДФЛ в поле под номером «040», соответственно, налоговые вычеты – в строке «030», а начисленный доход отражается в строке «020».

Получается, что расчет исчисленного налога производится по следующей формуле:

«040» = («020» – «030») * СН, где СН – ставка налогообложения

Удержанным НДФЛ называют размер налога, удерживаемого в обязательном порядке из зарплаты и прочих доходов сотрудников. Здесь важно то, что сам факт удержания производится на основе сумм дохода, которые были получены по факту. Получается, что работодатель обязуется во время произведения выплат доходов в пользу сотрудников отправлять сумму налогов платежным поручением в госбюджет.

Прописывается удержанный налог в поле «070» в справке по форме 6-НДФЛ. При этом стоит учитывать, что размер указывается в этом случае нарастающим итогом, и отражается с момента начала года.

Порядок заполнения 6-НДФЛ

Если же доход получается сотрудником в форме материальной выгоды, а также в натуральной форме, НДФЛ удержать невозможно. Однако исчисление его все равно должно производиться из остальных видов финансовых поручений.

Согласно ст. 226 НК РФ, сумма удержанного налога не может быть выше, чем половина полученного дохода, исчисленного в деньгах. И в строке «070» должна отражаться сумма с выплат, которые производились именно на момент составления бухгалтером отчета.

Статья 226. Особенности исчисления налога налоговыми агентами

Главные уточнения

Исчисление налогов должно осуществляться не учитывая те доходы, которые получает плательщик налогов от прочих агентов, а также тех финансов, которые были удержаны сторонними агентами. Они, в свою очередь, должны удерживать начисленный налог именно при выплате зарплат плательщиков.

Удержание обязательно производится самим работодателем. Удерживаемая сумма не превышает 50% всех доходов.

Если удержание невозможно, агент должен в течение месяца с момента окончания налогового периода, в котором могли возникнуть сдерживающие обстоятельства, сообщить плательщику и органу ФНС в письменной форме о данном факте. При этом обязательно отражение суммы налога.

Отличия в 1С ЗУП

Оба типа налогов различаются в программе учета типом движения в регистре накопления, называемого «НДФЛ расчеты с бюджетом». Исчисленный НДФЛ отображается в регистре «+», удержанный – в «-«.

В «+» регистр двигаются отчеты по начислению дивидендов и зарплаты, в регистр «-» попадают документы РКО и банковские выписки. При этом в параметрах учета в строке «Расчет зарплаты» не должно стоять галочки напротив строки принятия исчисленного налога при его начислении в качестве удержанного.

В этом случае во время проводки документов «Начисление дивидендов» и «Начисление зарплаты» в регистр будут попадать две записи – в «+» и «-«. Суммы налогов будут одинаковыми.

Налог исчисленный и удержанный в НДФЛ может быть отличен во многих случаях. Например, если у сотрудника был переходящий отпуск с декабря месяца на январь.

В таком случае, в исчисленный НДФЛ попадает часть отпуска в декабре, а вот в удержанный попадет весь налог. Помимо этого, при превышении суммы исчисленного налога 50% доходов удержанный налог также будет отличаться от исчисленного – он будет меньше.

Суть различий

Сотрудники ФНС уверяют, что отличия сумм удержанного и исчисленного налогов могут возникнуть только в том случае, если расчеты были ранее сделаны неверно. По этой причине, если справка 2-НДФЛ отражает различия, то необходимо предоставление работодателем пояснительной расписки в орган ФНС, которая подтвердит верность расчетов.

При составлении пояснительной записки бухгалтер имеет возможность лишний раз проверить верность своих расчетов и выявить неточности в отчете. При выявлении ошибки необходимо также предоставить в ФНС копию платежного поручения, в которой должна отражаться сумма налога, который был ошибочно не перечислен.

Если в отведенный период не оплатить налог или вовсе не сделать этого, работодатель будет вынужден уплатить штраф в размере 20% от общей суммы вычета.

Особенности учета

Согласно ст.226 НК РФ, удержание начисленного налога у сотрудника должно производиться за счет любых денег, которые ему выплачиваются, причем делаться это должно именно в момент получения этих финансов. Но в Кодексе нет пояснений о том, что именно нужно считаться под понятием «сумма выплаты».

Методисты «1С» предлагают следующую формулировку этого термина – деньги, которые либо выплачиваются через кассы на руки сотруднику, перечисленные на его банковский счет. Поэтому, сумма удержанного налога физически не может превысить общую сумму денег, которые были им получены за отчетный период. При этом данная интерпретация термина может корректироваться.

В стандартной конфигурации деньги, которые перечисляются на банковский счет работника или выдаются на руки через кассу, должны регистрироваться проводкой «Выплата зарплаты». Если средства перечисляются на счета сторонних лиц по требованию работника, то такие финансы регистрируются как «Перечисление ЗП в банк».

Работающие граждане, получающие заработную плату, с которой удерживается 13% НДФЛ, имеют право на возврат подоходного налога за лечение зубов.

Узнайте из статьи о подоходном налоге с продажи автомобиля в 2019 году.

Исчисление удержанного налога производится после того, как деньги будут выплачены сотруднику. Для этого в стандартной конфигурации предусматривается специальный режим, чтобы произвести групповой расчет ЗП.

Если на предприятии могут возникать задержки зарплаты, и в каком-то из отчетных периодов работники денег не получали, то предприятие в роли налогового агента не имеет права на удержание со своих работников исчисленного налога. Соответственно, записи по удержанным налогам окажутся нулевыми. При погашении задолженности в следующем отчетном периоде, компания будет удерживать исчисленный налог за оба месяца.

Оговорки насчет значений

Также возможно возникновение таких ситуаций, когда исчисленный налог оказывается меньше удержанного и наоборот. Такие ситуации вполне допустимы и при правильном расчете налогов, поэтому, считать такие случаи ошибочными не стоит. Разберемся, почему могут возникнуть такие ситуации.

Меньше

Если удержанный налог меньше исчисленного, то необходимо проверить в программе настройки. Сначала стоит внимательно изучить налоговую карточку (1-НДФЛ). Нужно здесь найти первый месяц из всех 12, в котором случилось первое расхождение между типами налогов.

После этого стоит зайти в регистр «НДФЛ расчеты с бюджетом», классифицировать записи по определенному сотруднику за весь отчетный год и произвести проверку движений по такому регистру в первом месяце, где были зафиксированы расхождения. Нужно просмотреть движения «+» и «-«.

После этого должна быть произведена проверка по работнику за этот же месяц платежных документов в регистре «Расчеты с бюджетом». Необходимо выявить отсутствие и наличие записей по платежным документам.

Здесь проблема вполне могла появиться вследствие изменения положения галочки по принятию исчисленного налога в качестве удержанного при начислении налога. Это можно увидеть в настройках учетных параметров.

После проделанных операций нужно перепровести документы по выплате и начислению ЗП по возможности. Если такой возможности нет, то производится корректировка посредством документа на соответствующих закладках «Корректировка учета по НДФЛ, ЕСН и страховым взносам».

Больше

Если удержанный налог больше исчисленного, то здесь, скорее всего, та же самая проблема – галочка о принятии исчисленного налога в качестве удержанного при начислении НДФЛ. Этой галочки стоять не должно. Обязательно стоит еще раз просмотреть отчет, и если галочка все же стоит, то убрать ее. Также в разделе «Выплата зарплаты» поставить флажок напротив строки «Упрощенный учет взаиморасчетов».

Это не все. Нужно затем перепровести снова все выплаты и начисления в верной последовательности – ЗП, отпускные, больничные. После проведения этих операций отчетность примет правильный вид.

Несовпадение

Тот же самый способ работает и при несовпадении значений. Также стоит проверить наличие/отсутствие галочки о принятии исчисленного налога в качестве удержанного, после чего заняться перепроводкой всех платежных документов. Обычно после проведения такой операции значения начинают совпадать, но для этого необходимо соблюдать верную последовательность выполнения операций и быть максимально внимательными.

Часто задаваемые вопросы

Какие сроки устанавливаются для того, чтобы налоговый агент исполнил обязательства по оплате НДФЛ? Согласно ст. 226 НК РФ, исчисление налога должно быть произведено в момент получения дохода по факту. Удержание производится при выплате зарплат и прочих типов дохода в деньгах. Перечисление суммы обоих типов налога должно производиться не позже дня, который следует за днем выплату денег плательщику. В роли исключений выступают ситуации по выплате больничных средств и отпускных.
Как происходит определение даты получения зарплаты? Зарплата должна выплачиваться не реже двух раз в месяц. С октября 2019 года дата выдачи ЗП не устанавливается правилами трудового распорядка внутри предприятия позже, чем истечение 15 дней после окончания периода начисления. Определить полученных доход в виде ЗП нельзя до истечения месяца, также невозможно в этом случае и исчисление налога НДФЛ за первые полмесяца.
Когда работодатель должен перечислят налог с ЗП? Момент удержания налогов может не совпадать с датой фактического получения ЗП. Агентом удержание и перечисление производится каждый месяц после полного расчет с сотрудником по итогам отчетного периода, в которому ему начислялся доход. В 2019 году налог удержанный перечисляется не позже дня, который следует за моментом получения сотрудником заработанных средств.

Срок уплаты НДФЛ в 2019 году: налог необходимо уплачивать не позднее того дня, который следует за днем выплаты дохода.

Узнайте из статьи, какой НДФЛ при компенсации морального вреда.

Берется ли подоходный налог с премии — читайте .

Как заполнить 2-ндфл в 2017 году

В справке 2-НДФЛ сумма налога удержанная указывается в строке «Сумма налога удержанная». Перечисленный НДФЛ Это та сумма налога, которую налоговый агент фактически перечислил в бюджет. В справке о доходах 2-НДФЛ информации о сумме перечисленного налога отведено место в строке «Сумма налога перечисленная». Пример Зарплата работника составляет 30000 руб. в месяц, стандартные вычеты работнику не положены.

Работодатель исчислил сумму НДФЛ и полностью удержал его, но в бюджет перечислил лишь 50% от удержанной суммы.

НДФЛ Сумма Исчисленный 3900 руб. (30000 руб. х 13%) Удержанный 3900 руб.

Перечисленный 1950 руб. (3900 руб. х 50%) Получается, что на руки работник должен получить 26100 руб. (30000 руб. – 3900 руб.), а работодатель не до конца исполнил свои налоговые обязанности, т.к.

НДФЛ в бюджет поступил не в полном объеме. Рассмотрим такую ситуацию.

Например, с выигрыша в лотерею нужно заплатить 35%. 2-НДФЛ нужно сдавать раз в год до 1 апреля.

Если он выпадает на выходной или праздник, срок переносится на следующий рабочий день.

Не забывайте каждый квартал сдавать отчёт 6-НДФЛ. Подробнее о нём читайте в статье «Как подготовить отчёт 6-НДФЛ».

Правила заполнения формы 2-НДФЛ 2-НДФЛ состоит из справок на каждого сотрудника.

В справке отражается информация о доходах, вычетах, исчисленном, удержанном и перечисленном налоге.

Скачать форму 2-НДФЛ Правила заполнения 2-НДФЛ

  • Исчисленный налог — 13% от разницы между доходами и налоговыми вычетами.
  • Удержанный налог — сколько НДФЛ вы удержали из зарплаты сотрудника.
  • Перечисленный налог — сколько НДФЛ вы перечислили в налоговую.

Чаще всего трудности возникают при заполнении суммы перечисленного налога.

Сумма налога yt удержанная налоговым агентом в справке 2 ндфл что это

  • 1 <<
  • 2 Раздел 5
  • 3 Как сдать
  • 4 Уточненные справки

Раздел 5 В разделе 5 отразите общую сумму дохода и налога по итогам года. Этот раздел заполняйте отдельно по каждой ставке налога. Порядок заполнения соответствующих полей приведен в таблице.

Наименования поля Что указывать Справка с признаком 1 Справка с признаком 2 (сообщение о невозможности удержать налог) «Общая сумма дохода» Суммарную величину дохода по итогам налогового периода.

Для этого сложите все доходы, указанные в разделе 3. Налоговые вычеты, указанные в разделах 3 и 4, в этот показатель не включайте Общую сумму дохода, с которой не удержали налог «Налоговая база» Налоговую базу, с которой исчислен налог.

Кондратьеву в 2015 году, составила 144 000 руб. В декабре 2015 года по просьбе сотрудника организация оплатила ему туристическую поездку.

Дополнительный доход Кондратьева, полученный в натуральной форме, составил 60 000 руб.

Кондратьев является инвалидом II группы, поэтому в 2015 году он имел право на стандартный налоговый вычет в размере 500 руб.

в месяц.

Таким образом, общая сумма НДФЛ, исчисленная с доходов Кондратьева за 2015 год, равна:(144 000 руб.

– 500 руб. × 12 мес. + 60 000 руб.) × 13% = 25 740 руб. По состоянию на 1 января 2016 года организация смогла удержать из зарплаты Кондратьева НДФЛ только в размере 17 940 руб. 1 января 2016 года Кондратьев уволился. Разницу между исчисленной и удержанной суммой налога организация передала на взыскание в налоговую инспекцию.

Перечисленный НДФЛ и как с этим бороться

Для начала небольшой экскурс в методологию (цитата из статьи ИТС «Учет перечисленного в бюджет налога в разрезе физлиц»):

Учет перечисленного в бюджет НДФЛ в разрезе физических лиц в программе необходимо вести с целью автоматического формирования отчета «Регистр налогового учета по НДФЛ» и заполнения документов «Справка 2-НДФЛ» (как для сотрудника, так и для передачи в ИФНС) в части сумм перечисленного налога. Вести такой учет в специальном регистре обязывает статья 230 Налогового Кодекса РФ (далее НК РФ), о необходимости указывать такие суммы в справках 2-НДФЛ сказано в Приказе ФНС от 17 ноября 2010 г. N ММВ-7-3/611@.

Суммы перечисляемого в бюджет налога в общем случае могут не совпадать с суммами налога удержанного. Кроме того п. 1 ст. 230 НК РФ обязывает указывать в регистрах налогового учета реквизиты платежных документов, которыми была произведена уплата налога в бюджет РФ. Такой информации в подсистеме расчета зарплаты не содержится. Поэтому такие суммы регистрируются в программе отдельным документом «Перечисление НДФЛ в бюджет РФ».

Регистрация в учете сумм перечисленного налога осложняется тем, что НК РФ обязывает вести такой учет в отдельности по каждому физическому лицу, однако в бюджет налог перечисляется общей суммой, без указания по какому лицу какая сумма перечисляется. В настоящий момент не существует разъяснений контролирующих органов о том, как следует распределять перечисляемые в бюджет суммы налога между физическими лицами с целью ведения регистра налогового учета в соответствии с п. 1 ст. 230 НК. Поэтому методистами фирмы «1С» был предложен следующий подход к автоматизированному распределению сумм перечисленного налога.

В момент регистрации в учете удержанного НДФЛ (об этом моменте рассказано выше) в учете также регистрируется необходимость (обязанность) перечислить в бюджет удержанную по каждому физическому лицу сумму налога, при этом необходимость эта регистрируется в точности такой же датой, как и дата удержания налога. Т.к. необходимость перечислить налог напрямую связана с фактом удержания налога, а удержанный налог, как и исчисленный, регистрируется в учете в разрезе ставок налогообложения (13%, 30%, 9% и т.д.), месяцев налогового периода (т.е. месяцев, за который зарегистрирован доход и налог) и территориальной принадлежности (коды ОКАТО и КПП), то и суммы, необходимые к перечислению, регистрируются в разрезе этих признаков с целью обеспечения максимальной точности при распределении налога и отражении сведений о перечисленном налоге в регистре налогового учета.

Следующей датой в учете регистрируется факт перечисления налога в бюджет, т.е. вводится документ «Перечисление НДФЛ в бюджет РФ», в котором указывается общая сумма перечисленного налога, дата его перечисления, месяц налогового периода, ставка налогообложения, коды ОКАТО/КПП, а также реквизиты платежного документа. Общая сумма перечисленного налога, вручную указанная в документе, автоматически распределяется по физическим лицам пропорционально суммам, которые ранее (в момент удержания налога) были зарегистрированы как необходимые к перечислению.

Если общая перечисляемая сумма совпадает с общей суммой удержанного налога (т.е. удержанная сумма налога перечисляется полностью), то в результате такого распределения перечисленная сумма по каждому физическому лицу совпадет с суммой удержанной, зарегистрированной как необходимая к перечислению.

Конец цитаты.

В реальной жизни очень часто возникают ситуации, когда сумма перечисленного НДФЛ больше или наоборот меньше суммы НДФЛ удержанного.

В этих случаях программа ведет себя следующим образом:

1. Сумма НДФЛ перечисленного меньше чем НДФЛ удержанного: остаток недоперечисленной суммы НДФЛ «зависает» в регистре накопления «Расчеты налоговых агентов с бюджетом по НДФЛ» и «висит» до тех пор пока не будет введен еще один документ «Перечисление НДФЛ в бюджет». В этом документе необходимо будет указать месяц за который не до конца перечислен НДФЛ и заполнить его физ.лицами, имеющими этот остаток.

2. Сумма НДФЛ перечисленного больше чем НДФЛ удержанного: сумма излишне перечисленного налога записывается с минусом в регистр накопления «Расчеты налоговых агентов с бюджетом по НДФЛ». Такая задолженность на последующие месяцы налогового периода не переносится и не может быть зачтена в других месяцах. По словам методистов 1С, такой подход основывается на положениях НК РФ и подтверждается письмом ФНС от 19 октября 2011 г. N ЕД-3-3/3432@, в котором сказано: «… ежемесячное перечисление в бюджет суммы, превышающей сумму фактически удержанного из доходов физических лиц налога на доходы физических лиц, не является налогом. В таком случае налоговому агенту следует обратиться в налоговый орган с заявлением о возврате на расчетный счет организации суммы, не являющейся налогом на доходы физических лиц и ошибочно перечисленной в бюджетную систему Российской Федерации.»

Если учет НДФЛ перечисленного на Вашем предприятии ведется в соответствии с вышеизложенными рекомендациями, Вы не допускаете наличия «положительных» или ,не дай бог, отрицательных остатков, тогда дальнейшее чтение статьи для Вас будет бесполезно !

На данный момент существуют 2 известные мне методики избавления от «висящих» остатков по НДФЛ перечисленному:

1. Написание обработки, которая будет анализировать «висящие остатки» и сама создавать документы «Перечисление НДФЛ в бюджет»;

2. Изменение документа «Перечисление НДФЛ в бюджет» для закрытия «висящих» остатков одним документом.

Я предлагаю для рассмотрения второй вариант, а именно, добавление в модуль документа «Перечисление НДФЛ в бюджет» одной процедуры и одной функции, которые избавят Вас от «висящих» остатков в регистре накопления «Расчеты налоговых агентов с бюджетом по НДФЛ».

Но, для начала, давайте посмотрим как работает типовой механизм закрытия остатков по перечисленному НДФЛ.

Записи с «+» образовались при проведении двух документов «Начисление зарплаты» (за апрель и май 2011 года).

Записи с «-» движения стандартных документов «Перечисление НДФЛ в бюджет» (за апрель и май 2011 года).

Рассчитаем отстаток нераспределенной суммы НДФЛ (по месяцам налогового периода):

За апрель образовалась переплата = -446 = 2431 — 2877;

За май образовалась задолженность = 680 = 2431 — 1751.

В итоге имеем долг по перечисленному НДФЛ = 234 = 680 — 446.

Возникает вопрос, как закрыть задолженность и почему переплата за апрель не учлась в мае. Все просто! согласно письмом ФНС от 19 октября 2011 г. N ЕД-3-3/3432@ переплата за апрель не является налогом и автоматически зачитываться в типовой конфигурации не будет. Далее, чтобы зачесть задолженность за май необходимо ввести еще один документ «Перечисление НДФЛ в бюджет», в котором в качестве месяца, за который платят, будет указан май. Причем, именно май, т.к. например при перечислении налога за июнь неперечисленный НДФЛ за май автоматически зачитываться также не будет. При таком раскладе количество человеко часов работы бухгалтерии при хорошо разветвленной структуре фирмы и численности работников превышающей 2000 человек увеличивается до пугающих величин.

Теперь сравним с движениями измененного документа «Перечисление НДФЛ в бюджет».

Записи с «+», образовались при проведении трех документов «Начисление зарплаты» (за апрель, май и июнь 2011 года).

Записи с «-«, сформированы изменными документами «Перечисление НДФЛ в бюджет» (за апрель, май и июнь 2011 года).

Рассчитаем отстаток нераспределенной суммы НДФЛ (по месяцам налогового периода):

Апрель: переплата = -446 = 2431 — 2877. Обрабтите внимание, что сумма переплаты, в отличие от типового механизма, записывается отдельно (в май 2011 года).

Май: задолженность = 234 = 2431 — 1751 — 446. Документ «Перечисление НДФЛ в бюджет» за май 2011 года зачел переплату за апрель в размере 446 рублей, после чего сумму оплаты в размере 1751 рубль посадил целиком в май. Т.к. суммы оплаты нехватает, чтобы полностью погасить задолженность, следовательно возникает долг = 234 рубля.

Июнь: задолженность гасится = 0 = 234 + 120 — 354. Документ «Перечисление НДФЛ в бюджет» за июнь 2011 года гасит долг за май в размере 234 рубля, а также гасит долг за июнь в размере 120 рублей.

Результатом работы измененного документа явилось полное погашение задолженности по НДФЛ без ввода дополнительных документов «Перечисление НДФЛ в бюджет» и корректировок регистра.

Что же необходимо сделать, чтобы этот механизм заработал?

Первое, что необходимо — получить остатки НДФЛ по месяцам налогового периода. За это отвечает функция «ПолучитьТаблицуРаспределенияПоФизлицу»:

Функция ПолучитьТаблицуРаспределенияПоФизлицу(Физлицо) Экспорт

Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ РАЗРЕШЕННЫЕ РАЗЛИЧНЫЕ

| РасчетыНалоговыхАгентовСБюджетомПоНДФЛОстатки.ФизЛицо КАК ФизЛицо,

| НАЧАЛОПЕРИОДА(РасчетыНалоговыхАгентовСБюджетомПоНДФЛОстатки.МесяцНалоговогоПериода, МЕСЯЦ) КАК МесяцНалоговогоПериода,

| СУММА(РасчетыНалоговыхАгентовСБюджетомПоНДФЛОстатки.СуммаОстаток) КАК Долг

|ИЗ

| РегистрНакопления.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.Остатки(

| &Период,

| ФизЛицо = &Физлицо

| И Ставка = &Ставка

| И ОКАТО_КПП = &ОКАТО_КПП) КАК РасчетыНалоговыхАгентовСБюджетомПоНДФЛОстатки

|ГДЕ

| РасчетыНалоговыхАгентовСБюджетомПоНДФЛОстатки.СуммаОстаток <> 0

|

|СГРУППИРОВАТЬ ПО

| РасчетыНалоговыхАгентовСБюджетомПоНДФЛОстатки.ФизЛицо,

| НАЧАЛОПЕРИОДА(РасчетыНалоговыхАгентовСБюджетомПоНДФЛОстатки.МесяцНалоговогоПериода, МЕСЯЦ)

|

|УПОРЯДОЧИТЬ ПО

| ФизЛицо,

| МесяцНалоговогоПериода

|АВТОУПОРЯДОЧИВАНИЕ»;

Запрос.УстановитьПараметр(«Период» , Новый Граница(КонецДня(Дата), ВидГраницы.Включая));

Запрос.УстановитьПараметр(«ОКАТО_КПП» , ОКАТО_КПП);

Запрос.УстановитьПараметр(«Ставка» , Ставка);

Запрос.УстановитьПараметр(«Физлицо» , Физлицо);

Результат = Запрос.Выполнить();

ТаблицаРезультат = Результат.Выгрузить();

Возврат ТаблицаРезультат;

КонецФункции

Теперь процедура формирования движений по регистру накопления «Расчеты налоговых агентов с бюджетом по НДФЛ»:

Процедура СформироватьДвиженияПоФизлицу(Физлицо, Знач СуммаПеречислено)

ТаблицаРаспределения = ПолучитьТаблицуРаспределенияПоФизлицу(Физлицо);

ОтрицательныеСуммы = Новый ТаблицаЗначений;

ОтрицательныеСуммы.Колонки.Добавить(«МесяцНалоговогоПериода», Новый ОписаниеТипов(«Дата» , Новый КвалификаторыДаты(ЧастиДаты.Дата)));

ОтрицательныеСуммы.Колонки.Добавить(«Сумма», Новый ОписаниеТипов(«Число», Новый КвалификаторыЧисла(15,2)));

ПоложительныеСуммы = Новый ТаблицаЗначений;

ПоложительныеСуммы.Колонки.Добавить(«МесяцНалоговогоПериода», Новый ОписаниеТипов(«Дата» , Новый КвалификаторыДаты(ЧастиДаты.Дата)));

ПоложительныеСуммы.Колонки.Добавить(«Сумма», Новый ОписаниеТипов(«Число», Новый КвалификаторыЧисла(15,2)));

Для Каждого СтрокаТаблицаРаспределения из ТаблицаРаспределения Цикл

Если СтрокаТаблицаРаспределения.Долг > 0 Тогда

СтрокаТаблицы = ПоложительныеСуммы.Добавить();

СтрокаТаблицы.МесяцНалоговогоПериода = СтрокаТаблицаРаспределения.МесяцНалоговогоПериода;

СтрокаТаблицы.Сумма = СтрокаТаблицаРаспределения.Долг;

Иначе

СтрокаТаблицы = ОтрицательныеСуммы.Добавить();

СтрокаТаблицы.МесяцНалоговогоПериода = СтрокаТаблицаРаспределения.МесяцНалоговогоПериода;

СтрокаТаблицы.Сумма = -СтрокаТаблицаРаспределения.Долг;

КонецЕсли;

КонецЦикла;

// Закроем отрицательные суммы

Для Каждого СтрокаОтрицательныеСуммы из ОтрицательныеСуммы Цикл

ОсталосьРаспределить = СтрокаОтрицательныеСуммы.Сумма;

Распределено = 0;

Для Каждого СтрокаПоложительныеСуммы из ПоложительныеСуммы Цикл

Если СтрокаПоложительныеСуммы.Сумма > ОсталосьРаспределить Тогда

Движение = Движения.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.Добавить();

Движение.Период = ДатаПлатежа;

Движение.ФизЛицо = Физлицо;

Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

Движение.Организация = Организация;

Движение.МесяцНалоговогоПериода = СтрокаПоложительныеСуммы.МесяцНалоговогоПериода;

Движение.ОКАТО_КПП = ОКАТО_КПП;

Движение.Ставка = Ставка;

Движение.Сумма = ОсталосьРаспределить;

СтрокаПоложительныеСуммы.Сумма = СтрокаПоложительныеСуммы.Сумма — Распределено;

Распределено = Распределено + ОсталосьРаспределить;

ОсталосьРаспределить = 0;

Иначе

Движение = Движения.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.Добавить();

Движение.Период = ДатаПлатежа;

Движение.ФизЛицо = Физлицо;

Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

Движение.Организация = Организация;

Движение.МесяцНалоговогоПериода = СтрокаПоложительныеСуммы.МесяцНалоговогоПериода;

Движение.ОКАТО_КПП = ОКАТО_КПП;

Движение.Ставка = Ставка;

Движение.Сумма = СтрокаПоложительныеСуммы.Сумма;

Распределено = Распределено + СтрокаПоложительныеСуммы.Сумма;

ОсталосьРаспределить = ОсталосьРаспределить — СтрокаПоложительныеСуммы.Сумма;

СтрокаПоложительныеСуммы.Сумма = 0;

КонецЕсли;

Если ОсталосьРаспределить = 0 Тогда

Прервать;

КонецЕсли;

КонецЦикла;

Если Распределено > 0 Тогда

Движение = Движения.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.Добавить();

Движение.Период = ДатаПлатежа;

Движение.ФизЛицо = Физлицо;

Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

Движение.Организация = Организация;

Движение.МесяцНалоговогоПериода = СтрокаОтрицательныеСуммы.МесяцНалоговогоПериода;

Движение.ОКАТО_КПП = ОКАТО_КПП;

Движение.Ставка = Ставка;

Движение.Сумма = -Распределено;

СтрокаОтрицательныеСуммы.Сумма = ОсталосьРаспределить — Распределено;

КонецЕсли;

КонецЦикла;

// Сформируем записи на оставшиеся положительные суммы

Для Каждого СтрокаПоложительныеСуммы из ПоложительныеСуммы Цикл

Если СтрокаПоложительныеСуммы.Сумма = 0 Тогда

Продолжить;

КонецЕсли;

Движение = Движения.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.Добавить();

Движение.Период = ДатаПлатежа;

Движение.ФизЛицо = Физлицо;

Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

Движение.Организация = Организация;

Движение.МесяцНалоговогоПериода = СтрокаПоложительныеСуммы.МесяцНалоговогоПериода;

Движение.ОКАТО_КПП = ОКАТО_КПП;

Движение.Ставка = Ставка;

Движение.Сумма = Мин(СтрокаПоложительныеСуммы.Сумма, СуммаПеречислено);

СуммаПеречислено = СуммаПеречислено — Движение.Сумма;

Если СуммаПеречислено = 0 Тогда

Прервать;

КонецЕсли;

КонецЦикла;

// Оставшуюся переплату нужно посадить месяц налого периода из форму документа

Если СуммаПеречислено > 0 Тогда

МесяцНалоговогоПериода = НачалоМесяца(МесяцНалоговогоПериода);

Движение = Движения.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.Добавить();

Движение.Период = ДатаПлатежа;

Движение.ФизЛицо = Физлицо;

Движение.ВидДвижения = ВидДвиженияНакопления.Расход;

Движение.Организация = Организация;

Движение.МесяцНалоговогоПериода = МесяцНалоговогоПериода;

Движение.ОКАТО_КПП = ОКАТО_КПП;

Движение.Ставка = Ставка;

Движение.Сумма = СуммаПеречислено;

КонецЕсли;

КонецПроцедуры

И, наконец, комментируем строки типовой процедуры «ОбработкаПроведения()» и добавляем вызов процедуры «СформироватьДвиженияПоФизлицу()»:

Если Не Отказ Тогда

//Движение = Движения.РасчетыНалоговыхАгентовСБюджетомПоНДФЛ.ДобавитьРасход();

//ЗаполнитьЗначенияСвойств(Движение, ЭтотОбъект, «Организация, МесяцНалоговогоПериода, Ставка, ОКАТО_КПП»);

//Движение.Период = ДатаПлатежа;

//ЗаполнитьЗначенияСвойств(Движение, СтрокаТЧ, «ФизЛицо, Сумма»);

СформироватьДвиженияПоФизлицу(СтрокаТЧ.ФизЛицо, СтрокаТЧ.Сумма);

КонецЕсли;

Оставьте комментарий